Agni: Up and Running

So I got food poisoning.

From marshmallows.

What is this I don’t even.

——-

Anyway, Agni! I’ve ordered an IDE/ATA-to-USB connector cable, but it’ll be next week before it’s here, so in the meantime, let’s see what we have with Agni. Mercury, my previous box, used PS/2 connections for keyboard and mouse, but unfortunately, I’m only finding USB inputs.

Never fear, it came with a keyboard and mouse! ….oh. They’re ps/2 as well. Well. That’s. Helpful.

2013-03-02 11.07.52
This is a PS/2 connector btw.

So let’s see. I have a wireless usb mouse I’m using right now, and we have a usb keyboard attached to another computer, but we’d previously bought a kvm (Keyboard, Video, Mouse) switch that used ps/2 connections, so we’ll probably want a usb one of those in the long run. But I am determined to get this working. Determined, I tell you!

So we cannibalized a wireless USB mouse from a laptop and a USB keyboard from our desktop machine, figuring we’ll get it up and running and then control it via SSH until we can get the new kvm switch.

To install linux, I’ll need to make a bootable media so I can do the install. Except. We have a ton of DVDs, but it doesn’t read DVDs. It has a floppy drive, but it’s the only machine that does. I can’t seem to find any blank CDs, and I don’t want to reformat a USB stick since we’re using all of ours for data. Hmm. Decisions decisions.

Aha! My roommate to the rescue! He’s found a stack of blank CD-Rs and given me one. Now to download the AMD64 version of the debian network install (because I’ve got an AMD-brand 64-bit processor, as evidenced in post one).

Mercury ran xubuntu, keeping updated to each LTS version, but I think for Agni I’m going to just use ordinary debian + xfce. Since it’s a server, it can technically be run headless, but I have Chaos do tasks on the machine sometimes and he’s infinitely more comfortable with a GUI environment than a command line, so I like to put a lightweight GUI on the machine. XFCE is nice and small 🙂

Debian should also help avoid some of the weird issues I had with mercury installing apache into some non-default spot. I’m still not sure why that happened, but it seemed I had to modify every tutorial thanks to being on ubuntu instead of debian proper. Also he’ll match my new Rasberry Pi, which runs Rasbmc, which is Rasbian + xbmc, where rasbian is a debian fork for the raspberry. So they’ll match!

Wow that’s a lot of acronyms in two paragraphs. If you’re lost, never fear, have a marmoset:

Alright, back to work! So we need a usb keyboard…

but I don’t seem to have one? Goddamn, my tech stash is so inadequate. I’ve borrowed one from my husband’s laptop. Yet another thing to add to my list of stuff to purchase.

Anyway, with a borrowed wireless usb keyboard (James: “Won’t you need special drivers?” Me: “Betcha the install disk has them anyway.” Sure enough, It Just Works.), and a borrowed wireless USB mouse, we’re up and running! Agni now knows its name and speaks American English. I formatted two partitions out of the disk so I can keep the site data separate from the linux install in case I need to change distros or upgrade or something later on. It should also make backups easier.

Alright, debian installed, time to pop open a console and…

why is it black text on white background?! BIZZARE.

Anyway. Time to set up a static IP address. I just save off a backup copy of /etc/network/interfaces and change my settings… and it won’t come back up. Why did it fail? What is a “network” and what do I set it to? How about I strip the settings to the bare minimum? After ages of reading stuff off to one of my friends (since I’m having trouble reading this week, my vision’s been blurred due to some meds), we discover he didn’t hear a space when I read things off to him. Whoops.

Next problem: /sbin isn’t in our path? what? So I can’t use ifup… Fuck it. Reboot.

Nope, still not working. Okay. Restore from backup. Add interface eth0 to config file, but this time, use dchp instead of static. Test if it works now. Success! Ping google. Also success! Okay. So. That works for now. Screw it. I’m going to use my router to assign the IP address. ifdown, ifup, and we’re running.

Debian Wheezy and up install ssh by default, so now I can get into the box remotely. Huzzah. Except… connection refused. Joy. Maybe it didn’t install? apt-get install ssh… no, it’s there. Oh, maybe it’s not started? /etc/init.d/ssh start… nope. Could not load host key. Okay, that sounds like I need to regenerate the key somehow… more googling…

aha! ssh-keygen -t dsa -f /etc/ssh/ssh_host_dsa_key

So now SSH is up and running, time to install apache!

 

Leave a Reply

Your email address will not be published. Required fields are marked *